1,关闭 app的  grader.build下的implementation 对应sdk依赖。注释掉

2,去bmob官网下载sdk 压缩包,解压,找到lib文件夹。看到的是这样的:

https://www.bmob.cn/downloads

3,因为  3下面的几个jar是可以正常添加依赖的,就不需要额外手动添加了。只用添加1,2,3 。

在app下创建libs 文件夹,将  图片红框3放入:然后在src/main下创建JniLibs,将图片红框1,2 放入。

4,在app的gradler.build里include  libs库。并且创建so链接。

implementation files(’libs/BmobSDK_3.7.4_20190523.jar’)task nativeLibsToJar(type: Zip, description: "create a jar archive of the native libs") { destinationDir file("src/main/java") baseName "Native_Libs2" extension "jar" from fileTree(dir: "libs", include: "**/*.so") into "lib"}tasks.withType(JavaCompile) { compileTask -> compileTask.dependsOn(nativeLibsToJar)}

5,最后一步,去manifest.xml添加 bmobcontentprovder:

<provider android:name="cn.bmob.v3.util.BmobContentProvider" android:authorities="com.example.yangzi.multi_login.BmobContentProvider" />

com.example.yangzi.multi_login 是包名,具体项目需要进行替换。

总结

到此这篇关于android studio无法添加 bmob sdk依赖问题及解决方法的文章就介绍到这了,更多相关android studio添加bmob sdk依赖内容请搜索以前的文章或继续浏览下面的相关文章希望大家以后多多支持!